CISCO Lab # 6: Basic VLAN configuration in CISCO Switch

 

Tasks:

Configure the network as follows:
1) 3650 = layer 3 switch with IP addresses and interVLAN routing:
VLAN 1 = 10.1.1.254/24
VLAN 10 = 10.1.10.254/24,  
VLAN 20 = 10.1.20.254/24
VLAN 30 = 10.1.30.254/24,
VLAN 100 = 10.1.100.254/24  
2) Access layer switches will only have management IP addresses in VLAN 1:
Switch 1 = 10.1.1.1/24
Switch 2 = 10.1.1.2/24
Switch 3 = 10.1.1.3/24
3) Configure access ports as follows:
PC1 in VLAN 10 - 10.1.10.10/24
PC2 in VLAN 20 - 10.1.20.20/24
PC3 in VLAN 30 - 10.1.30.30/24
Server1 in VLAN 100 - 10.1.100.100/24
4) Configure ports between switches as trunks
5) Make sure that PCs can ping each other and the server
6) Make sure that switches can ping the PCs and server

Download Solved Lab

Solution:

We will first configure Layer 3 switch. We will define Switch Virtual Interfaces (SVIs) for each VLAN  and assign IP Addresses as mentioned in the step 1 of the lab.

Core>en
Core#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Core#vlan 10
Core#exit
Core#vlan 20
Core#exit
Core#vlan 30
Core#exit
Core(config)#interface vlan 1
Core(config-if)#ip address 10.1.1.254 255.255.255.0
Core(config-if)# no shutdown
Core(config-if)#exit
Core(config)#interface vlan 10
Core(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up
Core(config-if)#ip address 10.1.10.254 255.255.255.0
Core(config-if)# no shutdown
Core(config-if)#exit
Core(config)#
Core(config)#interface vlan 20
Core(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
Core(config-if)#ip address 10.1.20.254 255.255.255.0
Core(config-if)# no shutdown
Core(config-if)#exit
Core(config)#interface vlan 30
Core(config-if)#ip address 10.1.30.254 255.255.255.0
Core(config-if)# no shutdown
Core(config-if)#exit
Core(config)#
Core(config)#interface vlan 100
Core(config-if)#ip address 10.1.100.254 255.255.255.0
Core(config-if)# no shutdown
Core(config-if)#exi
Core(config)#

Next  we will configure port 20 to be part of VLAN 100 where the server is placed.

Core(config)#interface gigabitEthernet 1/0/20
Core(config-if)#switchport mode access
Core(config-if)#switchport access vlan 100
% Access VLAN does not exist. Creating vlan 100
Core(config-if)#
%LINK-5-CHANGED: Interface Vlan100, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up
Core(config-if)#exit

Next we will configure Trunk Interfaces


Core(config)#interface gigabitEthernet 1/0/1
Core(config-if)#switchport trunk encapsulation dot1q
Core(config-if)#switchport mode trunk
Core(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
Core(config-if)#exit

Core(config)#interface gigabitEthernet 1/0/2
Core(config-if)#switchport trunk encapsulation dot1q
Core(config-if)#switchport mode trunk
Core(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/2, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/2, changed state to up
Core(config-if)#exit

Core(config)#interface gigabitEthernet 1/0/3
Core(config-if)#switchport trunk encapsulation dot1q
Core(config-if)#switchport mode trunk
Core(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/3, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/3, changed state to up
Core(config-if)#exit
Core(config)#

Next we need to configure access switches. We need to assign IP Addresses to VLAN 1 interface and make the trunk as access interfaces

S1>
S1>en
S1#config t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#
S1(config)#interface vlan 1
S1(config-if)#ip address 10.1.1.1 255.255.255.0
S1(config-if)#no shutdown
S1(config-if)#
S1(config)#interface gigabitEthernet 0/1
S1(config-if)#switchport mode trunk
S1(config-if)#exit
S1(config)#interface fastEthernet 0/1
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10
S1(config-if)#exit
S1(config)#exit
S1#
%SYS-5-CONFIG_I: Configured from console by console
S1#


Similarly for the second switch

S2>
S2>en
S2#config t
Enter configuration commands, one per line.  End with CNTL/Z.
S2(config)#interface vlan 1
S2(config-if)#ip address 10.1.1.2 255.255.255.0
S2(config-if)#exit
S2(config)#interface gigabitEthernet 0/1
S2(config-if)#switchport mode trunk
S2(config-if)#exit
S2(config)#interface fastethernet 0/1
S2(config-if)#switchport mode access
S2(config-if)#switchport access vlan 20
% Access VLAN does not exist. Creating vlan 20
S2(config-if)#
S2(config-if)#exit
S2(config)#exit
S2#
%SYS-5-CONFIG_I: Configured from console by console
S2#


And finally third switch

S3>
S3>en
S3#config t
Enter configuration commands, one per line.  End with CNTL/Z.
S3(config)#interface vlan 1
S3(config-if)#ip address 10.1.1.3 255.255.255.0
S3(config-if)#exit
S3(config)#interface gigabitEthernet 0/1
S3(config-if)#switchport mode trunk
S3(config-if)#exit
S3(config)#interface fastEthernet 0/1
S3(config-if)#switchport mode access
S3(config-if)#switchport access vlan 30
% Access VLAN does not exist. Creating vlan 30
S3(config-if)#exit
S3(config)#exit
S3#
%SYS-5-CONFIG_I: Configured from console by console
S3# 

 

Next we will need to assign static IP Addresses to the server and PCs



 
 
 
 
Next we will test the connectivity from PC 1 to Server and other PCs.
 
 

We are able to ping Server from PC 1 and other PCs so our Lab is completed.

#buttons=(Accept !) #days=(20)

Our website uses cookies to enhance your experience. Learn More
Accept !