Topology
Configure Inter-VLAN Routing with Layer 3 Switch as following
Step 1: Cisco 3650 Layer 3 Switch VLAN Configuration
VLAN 1 = 10.1.1.254/24 (Management VLAN)
VLAN 10 = 10.1.10.254/24
VLAN 20 = 10.1.20.254/24
VLAN 30 = 10.1.30.254/24
VLAN 100 = 10.1.100.254/24 (VLAN for Server Connectivity)
Core(config)# interface Vlan1
Core(config-if)# ip address 10.1.1.254 255.255.255.0
Core(config-if)# interface Vlan10
Core(config-if)# ip address 10.1.10.254 255.255.255.0
Core(config-if)# interface Vlan20
Core(config-if)# ip address 10.1.20.254 255.255.255.0
Core(config-if)# interface Vlan30
Core(config-if)# ip address 10.1.30.254 255.255.255.0
Core(config-if)# interface Vlan100
Core(config-if)# ip address 10.1.100.254 255.255.255.0
Step 2: Assign Ports to VLANs on Layer 3 Switch
Core(config)# interface GigabitEthernet1/0/1
Core(config-if)# switchport trunk encapsulation dot1q
Core(config-if)# switchport mode trunk
Core(config-if)# interface GigabitEthernet1/0/2
Core(config-if)# switchport trunk encapsulation dot1q
Core(config-if)# switchport mode trunk
Core(config-if)# interface GigabitEthernet1/0/3
Core(config-if)# switchport trunk encapsulation dot1q
Core(config-if)# switchport mode trunk
Core(config-if)# interface GigabitEthernet1/0/20
Core(config-if)# switchport access vlan 100
Core(config-if)# switchport mode access
Step 3: Configure Management IP Addresses in Access Layer Switches
Switch 1 = 10.1.1.1/24
Switch 2 = 10.1.1.2/24
Switch 3 = 10.1.1.3/24
S1(config)# interface Vlan1
S1(config-if)# ip address 10.1.1.1 255.255.255.0
S1(config-if)# ip default-gateway 10.1.1.254
S2(config)# interface Vlan1
S2(config-if)# ip address 10.1.1.2 255.255.255.0
S2(config-if)# ip default-gateway 10.1.1.254
S3(config)# interface Vlan1
S3(config-if)# ip address 10.1.1.3 255.255.255.0
S3(config-if)# ip default-gateway 10.1.1.254
Step 4: Assign Ports to VLANs in Access Switches
S1(config)# interface FastEthernet0/1
S1(config-if)# switchport access vlan 10
S1(config-if)# switchport mode access
S1(config-if)# interface GigabitEthernet0/1
S1(config-if)# switchport mode trunk
S2(config)# interface FastEthernet0/1
S2(config-if)# switchport access vlan 20
S2(config-if)# switchport mode access
S2(config-if)# interface GigabitEthernet0/1
S2(config-if)# switchport mode trunk
S3(config)# interface FastEthernet0/1
S3(config-if)# switchport access vlan 30
S3(config-if)# switchport mode access
S3(config-if)# interface GigabitEthernet0/1
S3(config-if)# switchport mode trunk
Step 5: Configure PCs and Server connected on Access Ports of Access Switches
PC1 in VLAN 10 – 10.1.10.10/24
PC2 in VLAN 20 – 10.1.20.20/24
PC3 in VLAN 30 – 10.1.30.30/24
Server1 in VLAN 100 – 10.1.100.100/24
Step 6: Check Connectivity
- Make sure that PCs can ping each other and the server
- Make sure that switches can ping the PCs and server